WEB ASP help needed. Errors 403/500.

Discussion in 'OT Technology' started by Jesse, Jan 15, 2009.

  1. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Halp.

    http://www.ttb.siemens.com will load.

    http://www.ttb.siemens.com/en/ will not. Google says ASP config error.

    I've never used ASP before, and really don't know where to look. I do know the following versions are installed: 1.1.4322, and 2.0.50727.

    Web Service Extensions allowed: Active Server Pages, and each version of ASP. One was prohibited by default, I allowed it.

    Nothing has helped.
     
  2. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    I seem to get different errors in IE than in Firefox, too. :confused:
     
  3. SLED

    SLED build an idiot proof device and someone else will

    Joined:
    Sep 20, 2001
    Messages:
    28,118
    Likes Received:
    0
    Location:
    AZ, like a bauce!
    You need to set a default page under your /en/ folder in IIS. It's looking for the built in index.html default.aspx default.asp, etc and if it doesn't find one, it will display the "directory listing denied" error, which depending on what browser you use will look different since it's up to IE, FF etc to intemperate the error
     
  4. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    I enabled index.asp as one of the "documents" but it still did not find it. Does it need to be on the top of the list?
     
  5. f/2.8L

    f/2.8L New Member

    Joined:
    Oct 1, 2004
    Messages:
    4,762
    Likes Received:
    0
    Location:
    404
    Add index.asp to the Enabled Default Content Page box under the documents tab.

    Edit: And make sure 'index.asp' is in the /en folder.

    Edit2: You will also need to fix this, once you get the above fixed.

    Active Server Pageserror 'ASP 0131'
    Disallowed Parent Path
    /en/index.asp, line 27 The Include file '../include/navigation.asp' cannot contain '..' to indicate the parent directory.
     
  6. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Yeah I saw that. If that comes up, then the problem is within the code?

    I'm not the one coding it, I just manage the server.
     
  7. f/2.8L

    f/2.8L New Member

    Joined:
    Oct 1, 2004
    Messages:
    4,762
    Likes Received:
    0
    Location:
    404
    Yes, my Edit2 is a problem with the include file within index.asp.
     
  8. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    FYI, there are huge differences between ASP and ASP.NET. 1.1.4322 and 2.0.50727 are versions of the .NET Framework and are related to ASP.NET, meanwhile you are using classic ASP which has nothing to do with .NET.
     
  9. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Ahh.

    Noted.

    Which framework should be enabled? 1.x, 2.x, both?
     
  10. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    I have this showing on firefox, but still get error 500 in IE.

    Do permissions need to be set on the directories? :confused:

    In apache, doesn't error 500 typcially mean CHMOD is incorrect?
     
  11. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    Just try manually editing index.asp anyway, following those errors.

    On line 27 of index.asp try changing it to 'include/navigation.asp' and if that doesn't work try '/include/navigation.asp'. Have a look and see where this include/navigation.asp folder and file are (under en, or up a level?).
     
  12. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    "Include" directory is capitalized on the server. :slap:

    Cannot start with a slash, and ./include/navigation was not found.
     
  13. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    It's still an error 500, but IE will have friendly errors enabled so it's not showing the detail page from the server. HTTP 500 is a generic server error code so it can be anything.

    In IE you can go Tools > Internet Options, go to the Advanced tab, in the Browsing section, untick "Show friendly HTTP error messages" just above the underline links options.
     
  14. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    You don't need to worry about that. This site seems to be using classic ASP so it can't use .NET, so you don't need to worry about 1.x or 2.x.

    ASP is working, it's just a problem with the actual scripts themselves.
     
  15. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    Here this is probably what you need. My net is screwing up so I can't view this page but hopefully enabling this won't need any script file alterations: http://support.microsoft.com/kb/332117
     
  16. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    :bowdown:

    worked.
     
  17. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    ps, thank you
     
  18. BlazinBlazer Guy

    BlazinBlazer Guy Witness to The De-Evolution of Mankind.

    Joined:
    Jul 24, 2002
    Messages:
    18,783
    Likes Received:
    0
    Location:
    Lansing, MI USA
    looks like the exact opposite problem you originally posted is happening now:

    Active Server Pages error 'ASP 0126'
    Include file not found
    /index.asp, line 27
    The include file '../include/navigation-cn.asp' was not found

    Produced from http://www.ttb.siemens.com/

    Methinks you need to enable the use of parent paths in the IIS config.
     
  19. whup

    whup I wish you had children and.. so that I could step

    Joined:
    Feb 12, 2007
    Messages:
    1,603
    Likes Received:
    0
    No that's already been solved, the original error was "Disallowed Parent Path".

    That error looks like the file simply doesn't exist as it suggests with "Include file not found".
     
  20. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Yeah, the people who are working on this seem pretty incompetant. And they are in China, so they tell me something is broken, and they have to wait half a day for me to respond/fix it :rofl:
     
  21. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    I told them to disable "show friendly errors" - I'm pretty sure they ignored it, since they now have an error with uploading. Pretty sure they don't know how to spell "Attach"

    Code:
    Microsoft VBScript runtime  error '800a01b6'
    
    Object doesn't support this property or method: 'AttcachFile'
    
    /en/Berkeley_investor.asp, line 32 
     
  22. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Now I'm having issues getting the form email to send. I have an SMTP server set up for anonymous access. ANything I need to know?

    PM or AIM me - iamajesse, if you can help. Would be much appreciated.
     
  23. DarqueGT

    DarqueGT New Member

    Joined:
    Nov 29, 2004
    Messages:
    211
    Likes Received:
    0
    I use this for my SMTP emails....

    Code:
    Dim emailfrom, emailto, message, mymail, cid
     
    message="[COLOR=red][B]Whatever the message is...[/B][/COLOR]"
     
    Set myMail=CreateObject("CDO.Message")
    myMail.Subject="[COLOR=red][B]Put a subject in.....[/B][/COLOR]"
    myMail.From="[EMAIL="[email protected]"][B][COLOR=red]From address[/COLOR][/B][/EMAIL]"
    myMail.To="[EMAIL="[email protected]"][B][COLOR=red]To address[/COLOR][/B][/EMAIL]"
    myMail.TextBody=message
    myMail.Configuration.Fields.Item _
    ("<A href="http://schemas.microsoft.com/cdo/configuration/sendusing")=2">http://schemas.microsoft.com/cdo/configuration/sendusing")=2
    'Name or IP of remote SMTP server
    myMail.Configuration.Fields.Item _
    ("[URL]http://schemas.microsoft.com/cdo/configuration/smtpserver[/URL]") _
    ="[B][COLOR=red]PUT YOUR SMTP SERVER INFORMATION HERE[/COLOR][/B]"
    'Server port
    myMail.Configuration.Fields.Item _
    ("[URL]http://schemas.microsoft.com/cdo/configuration/smtpserverport[/URL]") _
    =[COLOR=red][B]25[/B][/COLOR] 
    myMail.Configuration.Fields.Update
    myMail.Send
    set myMail=nothing
    
    This has worked for me for the past year or so.....
     
  24. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Do you need to specify any smtp username/password/server anywhere?
     
  25. Jesse

    Jesse PSN: iamajesse; XBL: Inhale My Rod; G8 GT crew; Ne OT Supporter

    Joined:
    Jan 12, 2005
    Messages:
    25,649
    Likes Received:
    0
    Location:
    California :: (925)
    Here's what they are using..

    Code:
    <%
    function SendEmail(email_to,email_from,sSubject,sContents,attachFile)
    	sUserName = ""
    	sPwd = ""
    	sSender = "" 
    	sOrderNo = ""
    	
    	email_to   = Trim(email_to)
    	email_from = Trim(email_from)
    	attachFile = Trim(attachFile)
    	
    	Set MailSMTP = Server.CreateObject("CDO.Configuration")
    	Set MailObject = CreateObject("CDO.Message")
    		
    	Set Flds = MailSMTP.Fields
    	With Flds
    			.Item("http://schemas.microsoft.com/cdo/configuration/sendusing").Value = 2    'cdoSendUsingPort
    			.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver").Value = "pctc200x.us008.siemens.net"	'Mail server
    			.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate").Value = 1    'cdoBasic
    			.Item("http://schemas.microsoft.com/cdo/configuration/sendusername").Value = sUserName
    			.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword").Value = sPwd
    			.Item("http://schemas.microsoft.com/cdo/configuration/sendemailaddress").Value = sSender   
    			.Update
    	End With
    	
    	With MailObject
    			Set .Configuration  = MailSMTP
    			.To = email_to
    			.From = email_from
    			.Subject = sSubject
    			.Sender = sSender
    			.HtmlBody = sContents
    			.AddAttachment attachFile
    			if Len(email_from)>0 and Len(email_to)>0 then 
    			.Send
    			end if
    		
    	End With
    		
    End Function
    
    com_name=Request.form("com_name")
    address1=Request.form("address1")
    address2=Request.form("address2")
    city=Request.form("city")
    state=Request.form("state")
    zip=Request.form("zip")
    country=Request.form("country")
    txt_name=Request.form("txt_name")
    txt_title=Request.form("txt_title")
    email=Request.form("email")
    ph_num=Request.form("ph_num")
    web_address=Request.form("web_address")
    technology=Request.form("technology")
    Referred=Request.form("Referred")
    Description=Request.form("Description")
    upload=Request.form("upload")
    
    
    Contents="Company Name: "&com_name&"<br>"&"Street Address1: "&address1&"<br>"&"Street Address2: "&address2&"<br>"&"City: "&city&"<br>"&"State/Province: "&state&"<br>"&"Zip/Postal Code: "&zip&"<br>"&"Country: "&country&"<br>"&"Name: "&txt_name&"<br>"&"Title: "&txt_title&"<br>"&"Email: "&email&"<br>"&"Phone Number: "&ph_num&"<br>"&"Web Address: "&web_address&"<br>"&"Field of Technology: "&technology&"<br>"&"Referred By: "&Referred&"<br>"&"Short Description: "&Description&"<br>"
    
    
    SendEmail "[email protected]","seed_company","seed_company form",Contents,upload
    Response.Write("<script type='text/javascript'>alert('Your email has been sent. Thank you. We will get back to you shortly.');location.href='What to do.asp';</script>")
    
    'Response.write(Contents)
    %>
     

Share This Page