Apache/Fedora question on UserDir

Discussion in 'OT Technology' started by Coottie, Aug 18, 2006.

  1. Coottie

    Coottie BOOMER......SOONER OT Supporter

    Joined:
    Jun 6, 2006
    Messages:
    32,407
    Likes Received:
    0
    Location:
    OKC
    I just set up a Fedora 5 machine and I want to play around with web development. I want to set up user directories so I can just type http://ipaddress/~username and get to their directory. So in my httpd.conf file I added:

    LoadModule userdir_module modules/mod_userdir.so

    Then a little further down I changed the file to the following:

    Code:
    <IfModule mod_userdir.c>
        #
        # UserDir is disabled by default since it can confirm the presence
        # of a username on the system (depending on home directory
        # permissions).
        #
    #UserDir disable
        #
        # To enable requests to /~user/ to serve the user's public_html
        # directory, remove the "UserDir disable" line above, and uncomment
        # the following line instead:
        #
    UserDir public_html
    </IfModule>
    
    I set up a public_html folder under my main username and included an index.html file. The /home and /home/username and /home/username/public_html directories all have rwxr-xr-x permissions.

    My problem is whenever I use a URL of http://ipaddress/~username/ or http://ipaddress/~username/index.html I get the following error:

    Forbidden

    You don't have permission to access /~username/ on this server.

    I've tried everything I can think of....any suggestions cuz I'm totally stumped.
     
    Last edited: Aug 18, 2006
  2. piratepenguin

    piratepenguin New Member

    Joined:
    Jun 18, 2006
    Messages:
    1,067
    Likes Received:
    0
    Location:
    Ireland
    Look for <Directory> sections that might limit access to folders in /home.

    BTW in Ubuntu to setup user directories I just had to make a symlink in /etc/apache2/mods-enabled/ to /etc/apache2/mods-available/userdir.conf and /etc/apache2/mods-available/userdir.load. Then the main config file includes /etc/apache2/mods-enabled/*.

    There might be a similar way to set this up in Fedora.
     
  3. Coottie

    Coottie BOOMER......SOONER OT Supporter

    Joined:
    Jun 6, 2006
    Messages:
    32,407
    Likes Received:
    0
    Location:
    OKC
    Hmm....could this be the cause?
    Code:
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    
     

Share This Page