Anyone else experience this with autogeek.net?

Discussion in 'That'll Buff Right Out' started by albuffit, Feb 7, 2008.

  1. albuffit

    albuffit New Member

    Joined:
    Dec 23, 2007
    Messages:
    1,072
    Likes Received:
    0
    Location:
    Bay Area
    I purchased 2 edge pads like last month but never got a chance to use them as they were my backup.. when i opened one up, i notice that the centering was way off and makes the pad vibrate and spin uneveningly. i checked out the other one, still in the package, and it was the same..

    i emailed them and it took 2 days to hear back.. they ask for the order number and my name/billing. i responded right away and now i havent heard from them in like 3 days (no holidays or weekends). i really need some new pads!
     
  2. Labster

    Labster OT Supporter

    Joined:
    Sep 21, 2003
    Messages:
    5,717
    Likes Received:
    0
    Location:
    NE, OH
    I've never had anything but good experiences with Autogeek.
     
  3. cjj92yj

    cjj92yj Guest

    They were a bit slow recently on shipping when I ordered a bottle of OP. Took 8 business days. I guess it's not too bad really, but I ordered the same day from the same general region and got it in 3 business days. Both were supposedly shipped UPS ground. I wasn't in a real hurry though, since it's mid twenties here.
     
  4. albuffit

    albuffit New Member

    Joined:
    Dec 23, 2007
    Messages:
    1,072
    Likes Received:
    0
    Location:
    Bay Area
    did you get the onr? how do you like it? i didnt have any luck with it because i work on some dirty ass cars and need something stronger.. i hope it has a better use for you.

    i think shipping was like $7 but the box costed $2.. hope its ok that i kept the extra $1 for shipping.
     

Share This Page