WEB # 1 in Google for something not even trying for

Discussion in 'OT Technology' started by Comtrad, Jan 11, 2008.

  1. Comtrad

    Comtrad Guest

    Not sure how I got the position, I'm not complaining, but find it odd.

    Cloverfield Sneak Peak


    I threw up a crappy video on my nothing site, and it's #1 ahead of AOL, YouTube, and other big sites.


    I did nothing for SEO on it, and really haven't done any optimising to the site at all, since I just got it running a couple days ago.
     
  2. MaK10

    MaK10 OT Supporter

    Joined:
    Nov 13, 2004
    Messages:
    3,843
    Likes Received:
    0
    Location:
    Chicago Suburbs
    im 6th if you type in

    cloverfield

    just below all the official crap

    and 15th for your search query :)
     
  3. Mangos

    Mangos New Member

    Joined:
    Jul 10, 2005
    Messages:
    6,610
    Likes Received:
    0
    Location:
    Boston, MA
    weird, you don't even have those words in your title
     
  4. Comtrad

    Comtrad Guest

    exactly
     
  5. Comtrad

    Comtrad Guest

    and yours is a site dedicated to the movie.


    odd indeed.
     
  6. dawgboye

    dawgboye I'm a businessman who's commodity happens to be co

    Joined:
    Jan 16, 2006
    Messages:
    7,971
    Likes Received:
    0
    Location:
    A Smart Part of Town.
    clicks > content
     
  7. Comtrad

    Comtrad Guest

    Only 47 views on that page though...
     
  8. dawgboye

    dawgboye I'm a businessman who's commodity happens to be co

    Joined:
    Jan 16, 2006
    Messages:
    7,971
    Likes Received:
    0
    Location:
    A Smart Part of Town.
    hrmmm, then people must be linking to your page like a mofo then.
     
  9. dawgboye

    dawgboye I'm a businessman who's commodity happens to be co

    Joined:
    Jan 16, 2006
    Messages:
    7,971
    Likes Received:
    0
    Location:
    A Smart Part of Town.
    or, there was a glitch in the matrix
     
  10. MrBrotato

    MrBrotato New Member

    Joined:
    Sep 7, 2005
    Messages:
    5,558
    Likes Received:
    0
    Wirelessly posted via wap.offtopic.com (Dell Axim X50v: Mozilla/4.0 (compatible; MSIE 4.01; Windows CE; PPC; 240x320))

    Glitch in matrix, you will be moved to page 5 for all future searches.
     

Share This Page